RLDev for Dummies

What’s this?

Ah, I’m gonna update that with a guide on extracting audio and inserting your own, I just haven’t had the time today. The H-scene thing took a couple hours.

1 Like

I’m having some problems (again). This time I couldn’t be helped by the Internet. I had to exclude ocaml-3.09.3. Now I’m re-installing it. But this is what happens when I try to ./configure on cygwin:

$ ./configure
./configure: line 133: rm: command not found
./configure: line 134: touch: command not found
…/gnu/config.guess: line 38: sed: command not found
…/gnu/config.guess: line 1265: mkdir: command not found
…/gnu/config.guess: line 1265: mkdir: command not found
: cannot create a temporary directory in /tmp
Cannot guess host type
You must specify one with the -host option

I just want to stop in and mention that I can’t begin to say how grateful I am for all the work you’ve done for this topic, Taka. Really superb job.


Wow, that’s gotta be a pain…
Does this work?

./configure --build=unknown

Thankies~ Hopefully I’ll be able to get all the important stuff up soon.


I did the whole thing again and it worked, but there’s another problem with the final part. When I try to ./configure the src folder on rldev it searches for the previously installed stuff, but when it gets to ulex it searches for the version 0.3 of it. Baka Tsuki says the version is 0.8. Then, I downloaded ulex 0.3.

But I can’t install it. Perhaps it’s another installation method (that I don’t know). When I try to install it the same way I did with ulex 0.8. it says:

When you did this, did cygwin ask for ulex 0.3. too?

The final part? Are you at the point where you call this?

cd …/rldev/src/

If so, you don’t need to .configure.

1 Like

Even if I don’t it still keeps requiring the 0.3 ulex for the omake and omake install.

Hmm, I don’t remember having a problem with ulex. I doubt this’ll work, but you could try saving this to your src folder.
Can you continue the process without specifying ulex? You might have to go over the ulex steps again.

It might have worked even with the error, so try opening cygwin and typing kprl.

It didn’t work. It was supposed to… It was looking for ulex 0.8, and I installed it… So, why not?

What process? The config or the omake? Nope, it stops when ulex isn’t found. It says ulex is required for the build process. Ulex steps… You mean the installation? Edit: I tried the installation again. This is what happens when I type make all.opt in the ulex folder:

Maybe the installation didn’t work. Baka tsuki says that if it’s successfully installed it should appear something like: make[1]: Leaving directory. In this case it didn’t appear.

And when I type make install:

When I type kprl in cygwin it happens nothing. It just says: command not found.

Looks like you can’t reinstall without deleting it first, but that’s a lot of work, so don’t do that.

Hmm, I tested mine, and omake worked, and it didn’t mention anything about ulex.

Okay then, try extracting this to your cygwin folder.

Anyone want to share the binary result?

I’m already configuring my CygWin for ARM project. Considering the hassle, I don’t want to risk breaking it. :slight_smile:

Of rldev?
If it isn’t done with this method, and rldev isn’t ran through cygwin, it wont work on any of the post-Clannad VNs (I think.) It doesn’t for me, and there are a couple others who tried just using an uploaded version of my rldev.

The CMD woes.

Uploading the actual cygwin would be… Well, the folder takes up all of the free space on my C: drive…

Yes, I think any cygwin would run the binaries fine.

Okay, now it did find the ulex but the ulex it found was 0.7. And it requires 0.8 now that I downloaded that file you uploaded.

Huh, I guess so. Never tested it though, there might be problems.
Would these be fine? I don’t know much about the environment, but I assume I got those from the right location~

Ah, it might be messed up by the earlier change to the config file.
Save this to your rldev/src/ folder.


The configure was completed, but as for the omake:

Looks like you might have missed out libpng. If you open up the cygwin setup and search for libpng, it should show up under the devel category. It’s version 1.5.14.

[quote=“Takafumi, post:36, topic:917”]
Huh, I guess so. Never tested it though, there might be problems.
Would these be fine? I don’t know much about the environment, but I assume I got those from the right location~[/quote]

Just copying some dll and it works like charm, locating cp932.dat is a little bit tricky tough.

Oh right, well the rldev folder is pretty small, so I can quickly upload that.